5月 08

経理用ノートパソコンをWin10にアップグレード

青色申告と請求書用に使用している経理用ノートパソコン。
Win7 Pro 32bitをWin10にアップグレードしてみた。

ちなみにソフトはやよい青色申告11、請求書15が入っている。
請求書15は動作保障されているけど、青色申告11はサポート外。
事前に別のWin10マシンにインストールしてみたところ、特に問題はなかった。

ということで、経理用ノートパソコンのWin7をWin10に。
念ためにインストール用ISOも落としておく。
でめたし、でめたし。

5月 15

2015年5月のWindowsUpdateで環境変数が壊れる?

WindowsUpdate適用後に、何となく違和感が。
スクリプトが色々と正常に動いてないらしい。

なんとなくコマンドプロンプトで
「perl」
と打ち込んでみると
「内部コマンドまたは外部コマンド…」
と表示された。

嫌な予感がする。
コンピューターのシステム詳細設定から環境変数を確認してみた。
ユーザーの環境変数でPATHが
「C:\Program Files\Intel\WiFi\bin\;C:\Program Files\Common Files\Intel\WirelessCommon\」
だけ。
システム環境変数でPathが
「」
つまり空。
やってくれたな、WindowsUpdate。
これはかなり厳しい事態。
さすがに、pathのバックアップなんてとってなかった。
なんてこったい。

それか、ノートン先生がウィルスなどを通してしまったか。

2月 27

ImageMagickでEPSに変換したファイルをIllustrator CS5で開くとフリーズする問題

ImageMagickのconvertコマンドでJPEG形式の画像ファイルををEPSファイルに変換したものを、Illustrator(イラストレータ) CS5で開くと、CS5が固まる問題を調査しました。
この現象を確認したのは、CentOS上で変換したJEPGファイルです。
昔はこんなことは無かった気がしますが、いつの間にかこの問題が発生していたので調査しました。

開発環境:
Windows7(64bit)
mageMagick 6.8.3-0 2013-02-13 Q16
Illustrator CS5

本番環境:
CentOS Linux 5.11
ImageMagick 6.2.8 05/07/12 Q16

CentOS上のImageMagickでJPEGファイルをEPSファイルにconvertしたものをイラレCS5で開くとイラレが固まって強制終了するしかなくなります。
単純に変換するときのコマンドです。
convert a.jpg a.eps

環境それぞれで生成されたEPSファイルを比較しました。
本番環境で生成したファイルにはヘッダ情報に

%begin_xml_code
<?xpacket begin="" id="W5M0MpCehiHzreSzNTczkc9d"?> <x:xmpmeta xmlns:x="adobe:ns:meta/" x:xmptk="Adobe XMP Core 5.0-c061 64.140949, 2010/12/07-10:57:01        "> <rdf:RDF xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"> <rdf:Description rdf:about="" xmlns:xmpMM="http://ns.adobe.com/xap/1.0/mm/" xmlns:stRef="http://ns.adobe.com/xap/1.0/sType/ResourceRef#" xmlns:xmp="http://ns.adobe.com/xap/1.0/" xmpMM:OriginalDocumentID="xmp.did:A379835BBF2068118A6DF5258C3E39CC" xmpMM:DocumentID="xmp.did:660D7D5C2F0F11E3A9DB9D247D1C6687" xmpMM:InstanceID="xmp.iid:660D7D5B2F0F11E3A9DB9D247D1C6687" xmp:CreatorTool="Adobe Photoshop CS5.1 Macintosh"> <xmpMM:DerivedFrom stRef:instanceID="xmp.iid:A56F4D9AC92068118A6DF5258C3E39CC" stRef:documentID="xmp.did:A379835BBF2068118A6DF5258C3E39CC"/> </rdf:Description> </rdf:RDF> </x:xmpmeta> <?xpacket end="r"?>
%end_xml_code

というものが追加されていました。
MACのフォトショCS5.1で保存されたとの記載を確認できます。
簡単に言うとファイル情報ですね。
これを削除するとイラレは固まらずにファイルを開けます。
よ~くソースを見ると、
「%begin_xml_code」と「%end_xml_code」に挟まれた行、XMLで言うところの「<?xpacket />」がベタで書かれていました。
この行、ソースとしてはベタで書かれていてちょっと引っかかったので、行をコメントアウト、つまり先頭に「%」を追加すると、イラレで固まらなくなりました。

XMLをPostScriptにベタで書いているので構文エラーで固まっていたようです。
PostScriptにはヒアドキュメントはなかった気がするので、stremaとしてデータとして埋め込むか、1行ずつコメントアウトしてやらないとだめなのでしょう。

XML情報は特に必要がないので、除去するオプション「-strip」を追加してconvertしてみます。
convert a.jpg -strip a.eps
これでファイル情報が格納されなくなり、イラレで無事開けるようになりました。

ファイル情報が埋め込まれるかどうかはコンパイル時のスイッチ設定だとは思うのですが、そこまでガッツリ調べるのが面倒なので、回避方法を確認したところで良しとします。

でめたしでめたし。

9月 12

Windows7にもてあそばれる

一通り入れた後に、MySQLを入れ忘れたのに気がついて入れてみたところ、PHPからアクセスできない。実際にはphpMyAdmin3からアクセスできない。エラーメッセージも表示されず、1分ぐらい待たされて方真っ白な画面になってしまう。
コマンドからは問題なくアクセスできるものの、mod_phpからアクセスできない。
このときのPHPは5.3.3、MySQLは5.1.50(64bit)でした。
httpd.confやphp.iniやmy.iniをいじっては見たものの改善せず。
ここで不貞寝しました。

そして翌日。
まず最初にMySQLをノーマルからエッセンシャルに入れ替えたり、32bitにしたりバージョンを入れ替えたりしたけれどうまくいかない。PHPを入れる際にVCのライブラリを更新したのでそれに問題があるのではと考え、仕方がなくWindows7を入れなおすことに。

とりあえずWindows7を上書きでインストールしなおしてみたところ、前のシステムが複製されて残っていて、とっても気持ちが悪い状態に。仕方がないので改めてパーティションをフォーマットしなおしてから、改めて入れなおすことに。

まず最初にMySQL5.1.50(64bit)を入れて、次にApache2.2.16、そしてVCを更新せずにPHP5.3.3を入れなおしてみたところ、やはり現象は同じ。
ここでふとPHPのインストーラーにVCの対象を選択する新しい項目があったのを思い出して、前のバージョンで試してみようと思い立ちました。
PHP5.2.14を入れなおしたところ、zlib.dllがないといわれるのでネットから拾ってきて放り込んだところ、難なく起動。

問題だったのはPHP5.3.3.
データベースとの連携が高いはずのPHPで、このような障害が発生しました。
何でもかんでも組み込み関数にしてしまったPHPの成れの果てを垣間見た気がしました。

結局それ以外では、ActivePerlを64bitにするとMinGWと連携できないようなので、32bitで入れなおしたぐらいで、特に大きな問題もなく開発環境は整いました。
あとはデータを移していくだけです。これもかなり面倒なのですが。

10月 25

Windows7に触れてきた

10月22日に発売になった新OSのWindows7ですが、今のメインマシンはVistaですが開発機ということもあって、簡単にOSを入れ替えることはできません。
もちろんアップグレード代1万5千前後も結構な負担というのもありますが。
とはいえ、まったく興味がないわけでもないので、量販店に行って弄ってきました。
第一印象としては、Vistaのスキンを変更したって感じです。いろいろいじっても特に違和感は感じないし、[win]+[e]の長押しもエクスプローラーが起動しまくるのも顕在でした。それ以外には何も感じません。多少ハードスペックが低くてもサクサク動くようですが、どの道使い込んだらモタつくのはWindowsのお約束でしょう。とりあえず、のんびりと様子を見ることにします。

9月 26

Windows Vistaにサービスパック2をインストールしてみた

先日、夜中にパソコンを起動したままにしていると、なにやら更新をダウンロードしはじめました。
かれこれ2時間ぐらい?でダウンロードを終えて、更新をしてもいいかと問われ、内容を見てみるとなんとSP2。
RC版のレビューはいろいろ読んでいたので、速くなってくれればありがたいから更新を開始してみた。

・・・なっかなか進まない。

・・・まだ終わらない。

朝10時ぐらいから初めて、結局終わったのは15時ごろ、つまり5時間もかかったのです。
ちなみにパソコンのスペックはCode2Duoの2.6GHz、メモリは1Gです。
まぁ、さんざん時間をかけて更新が終わり、いざ起動してみると・・・
起動が完了するまでは今までと何も変わらないが、もっさり感がなくなった。
普通に作業を終えて終了してみると・・・
は、速い!
いままで5分ぐらいかかっていた終了時間が(←これマジで)30秒程度で完了!
いまでも気持ちよくサクっと終わってくれます。

まぁ、パッチを当てて状態が変わったからでしょうが、できればこの快適さを維持してほしいものです。
なお、画面が良く固まる減少もぜんぜん見なくなりました。
とはいえ、まったくなくなったわけではなく、固まる回数がかなり減ったというだけですが・・・

7月 20

今頃WindowsVistaのReadyBoostを使ってみる

量販店で4GのSDHCカードがワゴンセールされていたので買ってみました。
ノートに備え付けのリーダーもろくに使っていなかったためか、認識に渋ってくれましたが、とりあえず設定を済ませました。

う~ん。
速くなったようななってないような。
でもアプリの起動速度は地味に早い気がするのかも?