3月 31

SaaSes終了で大わらわ

はい、サービスの動きを追っていませんでした。
分散していなかったのも悪いのですが。

ということで、必死に移設作業中です。
結局rsyncをものにしていないので、FTPで落としてあげ直すという気の遠くなる作業です。

とりあえずまずは使い慣れたDTIでVPSを借りてセットしたのですが、
基本的なものは問題ないものの、ImageMagickかGhostscriptかPerl-Magickかが非常に遅い。
クソ重いんです。

ということで、セットアップ終わったけどまた新しくさくらにVPSを借りて位置から再セットアップ中です。
上手くいきますように…

1月 23

プリントライ鯖ダウンと復旧

印刷通販サイトプリントライを運営しています。
先日20日、鯖の調子がおかしくなりました。
現在23日問題なさそうで、一件落着ということでブログに残しておきます。
本当はリアルタイムに書けばいいんだろうけど。

さて、朝は問題なかったのですが、工場に移動してアクセスするとMySQLのエラーがずらり。
ちなみに、このシステムはSaaSesのVPSに入れてあります。
なので、用意されているコントロールパネルを確認すると再開中の文字のまま変化なし。
Webminを確認しようとするも10000番ポートはアクセスできず、メールもFTPも駄目。
非常にまずい状態なのでサポートに問い合わせたものの返事がないこと3時間。
だめもとでtwitterのSaaSesManに言ってみたけど反応は無し。
印刷用のデータはすでに落としてあったので問題ないものの、出荷表を印刷できないので手動で登録を始めようと準備していると、復旧の通知メールが。
そこで確認すると、システム的に損失は無さそう。

今確認すると、24時間サポートの表記が見つからなかったり、運営にすこし疑問を感じていますが、すぐにどうにかできるものでもないので様子見です。

11月 25

CentOS6にProFPTdをインストールする

にっぽつ鯖を自宅鯖からSaaSesのVPSへ移動するため、CentOS6をセットアップしています。
基本部分はSSHでシコシコ追加して、あとはFTPでファイルをアップロードしようとProFTPdを追加しました。
RPMForgeから追加して起動までは問題ないものの、ログインができません。
サーバは応答しているものの、ユーザ名やパスワードを何度確認しても駄目です。

検索してみると、ちらほら同じ症状の記事があり、参考に修正してみましたが駄目でした。

結局は、「/etc/pam.d/proftpd」の内容を、海外のサイトにあったもので上書きして事なきを得ました。


#%PAM-1.0M-1.0
auth required pam_listfile.so item=user sense=deny file=/etc/ftpusers onerr=succeed
auth required pam_shells.so
auth include system-auth
account include system-auth
#session include system-auth
session required pam_loginuid.so

PAMとかよくわかりませんが、仕様変更に対応していないのでごにょごにょするといった感じのようです。
ファイルを更新して「service proftpd restart」で無事ログインできました。
でめたしでめたし

2月 17

FTPでPASVの設定を忘れていた

SaaSesでVPSを借りています。
新しいシステム用にちょっとだけランクのいいサービスを契約しました。
そのシステムのバックアップでFTP経由でファイルをミラーリングしていたのですが、接続がブチブチ切れて大きなファイルをダウンロードできない現象が頻発していました。
VPSに入れていたFTPサーバはProFTPDです。
しばらく放置していたのですが、FTPクライアントのソフトを見ていて気がつきました。PASVモード接続にチェックが入っていませんでした。
そこでチェックを入れてみたものの、ログインしてもリストを取得できない、これはファイアウォールの設定か何かかと思って眺めていても、埒が明きません。
よくよく調べてみると、PASVモード用にポート番号を設定する必要があると判明。
SaaSesのVPSはWebminで管理できますが、Webminの管理ツールからPASVモードの設定は1.530の現在では出来ないようです。
なので、設定ファイル編集より直接編集します。
最後に

# PASVモードで使用可能なポート番号範囲
PassivePorts 7030 7050

とおまじないを書いて保存、適用します。
さらに、Linuxファイアウォールで該当のポートを空けて適用すればPASVモードで接続が出来るようになりました。
でめたし、でめたし。

そういえば、回線のせいかもとツイートした気がします。日本ラッドさん、ごめんなさい。